叶雨梧桐BLOG

解决Fusetools配置的几个坑

发布时间:2015年12月26日 / 分类:Fuse / 吐槽

特殊原因不上图了。

问题1,由于大天朝GFW的原因造成的fuse install android个别组件配置失败的问题

首先查看安装的状态,执行fuse install -s android查看安装情况
理想情况下安装成功的话会提示 android is installed.
如果不是这个提示,那么恭喜你中奖了。再看一下提示的具体内容。分别验证了四个组件。jdk、androidsdk、androidndk、ant。查看具体是哪一个not found,再手动进行安装。所谓安装就是下载下来解包。至于path配置,则直接手动修改.sdkconfig文件内容即可。

问题2,build时提示sdk platform tools component is missing,please install it with the sdk manager。

这个问题就清晰明了了,打开sdk manager 安装对应版本的build-tools和platform-tools就可以解决。同样的因为大天朝天时地利人和的关系,需要你对源进行调整才可以完成,安心,爬是爬不出去的。估计是google链接的问题吧,总是failed。

解决方法:
1.启动 Android SDK Manager
2.打开主界面,依次选择「Tools」、「Options...」,弹出『Android SDK Manager - Settings』窗口
3.在『Android SDK Manager - Settings』窗口中,在「HTTP Proxy Server」和「HTTP Proxy Port」输入框内填入mirrors.neusoft.edu.cn和80,并且选中「Force https://... sources to be fetched using http://...」复选框
4.设置完成后单击「Close」按钮关闭『Android SDK Manager - Settings』窗口返回到主界面
5.依次选择「Packages」、「Reload」

问题3,build报错 Unable to resolve target android-19

此处就抓虾了,查到的资料是说修改工程目录下的project.properties文件里的内容target=android-19为自己的版本就好了。但特喵的,叶雨不是原生android,只是经过编译才会生成工程文件,这玩意没法前期进行修改啊,然后想着投其所好,直接安装19不就好了嘛,没想到果真如此。

解决方法,延续问题2,打开sdk manager 选择api 19 安装即可。

小结

1.以上问题出现的环境:win8.1 64bit fuse0.9.4

2.如果问题1不存在的话,目测下面两个问题也不会存在。

3.以上问题2和问题三分别参考以下两篇文章,表示感谢
http://blog.csdn.net/singleton1900/article/details/12911333

http://blog.csdn.net/love_javc_you/article/details/37728355

标签:没有标签呢

版权声明:除特殊注明外,均由叶雨梧桐原创,转载请保留文章出处;
本文链接:http://gt520.com/fuse/346.html
订阅叶雨梧桐BLOG RSS
分类
最新文章
最近回复
  • 楚狂人博客: 很久没看到博主新文章了,等待
  • 啊啊: 如果对象是隐藏的话还是不行
  • 通古思: PHP是世界上最好的语言!
  • 森七: 想转去ty,收藏了贵站肯定会用到 make
  • 寻芜兮: 博主您好,您写的《Xshell 进行科学上网的正确姿势》中图片已经挂掉了,可以再补档一次吗。
  • 天津网站建设: 感谢博主分享
  • 博客大全: 钻研精神会让你学到更多,加油!
  • 麦麦米: 不错的文章呢
  • 薇洛迪兰: 应该是服务器的问题吧
  • 关于我们: 弱弱的问下博主,接受友情链接吗?
归档